Can't log in, failed patch message, client version invalid...



  • Hi there, after installing the game and after all the patches went through, I get this message:
    "Linkrealms could not be located on your system. Re-install Linkrealms and then run this patch again"
    Then it says:
    "Patch failed. Your game client may be out of date and not function properly"

    Then the Patchnews opens up giving me the option to 'start' the game and the login screen (put my info) and lastly I get this message:
    "Your Client Version is Invalid....Complete all the patches proposed"



  • i got the same problem... the client on the website wont allow me to patch up to the most recent one.



  • @hiddenpocket @zigarachi on what drive have you installed Linkrealms? Did you use the suggested path?

    If it's not on the C drive, please try to re-install the game there and under the default path, that is:

    C:\Program Files (x86)\Linkrealms

    Let us know if that worked!



  • I deleted the (x86) from the default install location to this:

    C:\Program Files\Linkrealms

    That took care of the problem (after deleting everything and reinstalling)


  • FOUNDER: PRINCE

    I had to delete my lr restart my comp and then reinstall. When I uninstalled and immediately reinstalled if didn't work.



  • @Prometheus So yes the files were in C: drive, but just in case I deleted it all and reinstalled it; kinda got stuck adding the patches (almost seem like a looped patch) but then it got through to the PatchNews and hit 'start' and then it would dissapear and nothing would happen to a while until I would suddenly get the 'bug report' pop up stating the program froze. I tried 'sending ' the report but got an error saying I don't have a profile or something like that. Then the login screen shows up; I try signing in and I get the bug report again. And I'm stuck there.....(and not sure how to send the bug report).

    Update, I tried removing the (x86) when re-installing to see if that did anything, and same result...I don't get the patch issue any longer but I get the 'frozen' message bug report.



  • Getting the same error, done everything suggested in all the threads with this issue and nothing has worked.


  • FOUNDER: SETTLER

    @voicerader
    Just a few random suggestions that I read elsewhere that could possibly apply here. Try running it as administrator by right clicking the exe or icon and selecting the run as administrator option. Secondly try to rightclick on the Linkrealms folder and select properties. If the box that says read only has a square in it make sure to untick the box that says Read only and apply it. Once that process is finished try starting the game and seeing if it patches properly. Hope that works for you.



  • @Quikdeath You are a legend, thank you. For anybody that has the same problem, the second thing he offered as advice was the solution.


  • FOUNDER: SETTLER

    @voicerader Glad that worked for you! I think its a Windows 10 permissions issue that I have seen a few older games run into as well... Not sure though



  • Glad to hear that worked out for you guys!

    @hiddenpocket that is likely to be an antivirus issue, please have a look here:

    http://forums.linkrealms.com/topic/1048/fix-to-antivirus-issues-linkrealms-not-starting-freezing?page=1



  • @Prometheus Great Update guys! A little bit of everything helped! Last night I did part of the 'windows defender' set up (allowing the game), didn't work; I tried what @Quikdeath suggested with the 'read only' box, didn't work, and finally added the game to the scanner (quick scan) exception box and finally ...I'm in!!!! I'm sure the combination of it all worked.... Been waiting to play since Thursday so I just did a few things around the game, but I am exhausted from work and can't concentrate on the game...I will continue tomorrow! thank you guys!!



  • I am having an issue very similar but on Steam, when I try to login to the client through steam, and after I chose my character to finalize login, I get the following error:

    http://imgur.com/xMXBefD



  • @Wolfrick said in Can't log in, failed patch message, client version invalid...:

    I am having an issue very similar but on Steam, when I try to login to the client through steam, and after I chose my character to finalize login, I get the following error:

    http://imgur.com/xMXBefD

    Should also add in there when I do try to run it and this error occurs it removes my desktop taskbar, making everything all so enjoyable :).


Log in to reply
 

Looks like your connection to Linkrealms Forum was lost, please wait while we try to reconnect.